• Create BookmarkCreate Bookmark
  • Create Note or TagCreate Note or Tag
  • PrintPrint
Share this Page URL
Help

Part III: Appendixes > Backward Compatibility and Player Build Updates

Appendix C. Backward Compatibility and Player Build Updates

Flash allows you to publish .swf files in formats that are compatible with previous versions of the Player (via File Publish Settings Flash Version). By the time you read this, the majority of users will have at least version 6 of the Flash Player, but you may prefer to author for Flash Player 5 or 4 instead, such as when deploying to handheld devices that don't yet support Flash Player 6. Even if you are authoring exclusively for Flash 6, this appendix will help you avoid using deprecated ActionScript and bring you up to speed on the preferred methods in Flash 6. Furthermore, it will help you understand or upgrade legacy code that you may encounter.

See capabilities.version, getVersion( ), and $version in the ActionScript Language Reference for details on detecting the version of the Flash Player at runtime. See http://www.moock.org/webdesign/flash/detection/moockfpi for a version detection script that runs in the browser.



PREVIEW

                                                                          

Not a subscriber?

Start A Free Trial


  
  • Creative Edge
  • Create BookmarkCreate Bookmark
  • Create Note or TagCreate Note or Tag
  • PrintPrint